You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 47 Next »

Click Watch in the top right corner if you want to get an email when this tutorial is updated ========>

Overview

This tutorial will walk you through how to use Microsoft Excel to build a simple dashboard using CommCareHQ data exports.  By the end of the tutorial you will be able to create a dashboard that:

  1. Requires upfront work by an administrator just once, and then is easy to maintain going forward
  2. Refreshes automatically from CommCareHQ when you reopen the report (or set time based refresh).
  3. Allows users to filter the dashboard for information relevant to them without detailed knowledge of how Excel tables work.
  4. Enables an administrator to quickly make new reports and send to end users.

The intended audience for this page is a CommCare administrator who is familiar with CommCareHQ and has some experience in Excel.  The end result will contain the following:

**** Download the Example Dashboard **** 

 

A graphical dashboard

Individual pages with data:

User definable filters:

Getting Started

Excel Version: This tutorial was written for Microsoft Excel 2010. Most of the functionality described is also available in earlier versions of Excel though may be called different names.

Data Files:

Report Dashboard.xlsx: The Dashboard file.  Open this to see the final product.  *** You will get errors upon opening because the Raw Data file is not present, but just say OK and it will still work.  See Troubleshooting section at the bottom to point the file to your Raw Data ***

Raw Data.csv: The raw data downloaded from CommCare. Save this to your computer and follow the instructions in the Troubleshooting section at the bottom.

Export from CommCare.zip: The zip file that contains Raw Data.csv that is downloaded from CommCareHQ.

Step 1: Create Custom Export in HQ for the project

  1. See this page for details on creating the data export: Data Export Overview
    1. Name your export
    2. For Default File Type choose Excel 2007 as the Default File Type.  
    3. Choose Automatically convert dates for Excel
    4. Choose Create a Daily Saved Export
    5. Be sure to rename your Display columns to how you want them to display in your reports.
  2. Save the export

Step 2: Copy the Web Address of your saved export

When you chose to Create a Daily Saved Report in step 1, this meant every night CommCare will generate the export with all the latest data and save it. We will use this report to pull into Excel.

  1. Scroll to the bottom of the Data Exports Page
  2. In the Daily Saved Exports section you will see your saved export.
    1. ***Important*** It will take one night after creating the export for it to appear. CommCare saves the report nightly.
  3. Right-click on the link to the export
  4. Choose Copy Link Address in the menu. This will copy the URL of the export file so you can paste into Excel in the next step.

Step 3: Create the Excel Connection to your export

The next step is to create the file that will hold the reports.

  1. In Excel, Create a New File.
  2. You will have a blank Excel file now.
  3. Now we will pull in the data from the Excel file
  4. Choose the Data menu
  5. Choose Connections
  6. The "Workbook Connections" window appears. Choose Add... in the top right of the window
  7. The "Existing Connections" window appears.  Choose Browse for More in the bottom left of the window.
  8. The "Select Data Source" window appears. Paste the URL from Step 2 into the File name box at the bottom.
  9. Choose Open



  10. The "Windows Security" window appears. Type your CommCareHQ username and password.
  11. Excel will download the file. This may take a few minutes.
  12. The "Select Table" window appears.  Choose your sheet and click OK. (There should only be one option)
  13. The connection is now created. You should see "Connection" in the Workbook Connections window.  
  14. Rename the connection if you like by double-clicking it.

 

Step 4: Add the data to your Excel Sheet

  1. Go to a blank tab in your workbook. Rename that sheet "Raw Data".
  2. Select the top-left cell (A1).
  3. Choose the Data Menu
  4. Click Existing Connections
  5. The "Existing Connections" window appears. Double click the connection you made in the above step. It should be at the top of the window.
  6. The "Import Data" window appears. Choose Table and click OK.
    1. Note: you can choose PivotTable option here. This will make Step 5 unnecessary but the raw data will also not be visible to users. 
  7. Enter your CommCareHQ username/password if prompted.
  8. This will paste all you data into the workbook.
  9. See Step 10 for refreshing the data.

Step 5: Create the first Pivot Chart

The first chart we will create is the Line Graph of Expected Delivery Date.  This will plot the number of women expected to give birth in each month, broken down by Clinic.

  1. Create a new tab called "Expected Delivery Date"
  2. Select the top-left cell (A1) in this tab
  3. In the Insert menu choose Pivot Chart from the PivotTable icon
  4. In the window that pops up, click the icon next to "Table/Range" to select the data the pivot table will use.
  5. Go to the Raw Data tab and select all the columns
  6. The small window should populate with 'Raw Data'!$A:$E. Click the icon next to that.
  7. Click Ok.
  8. This creates a blank pivot table.
  9. Click the pivot table on the left
  10. In the Field list on the right, do the following:
    1. Drag Expected Delivery Date to "Row Labels"
    2. Drag District to "Column Labels"
    3. Drag District to "Values"
    4. Note: If you don't see the "Pivot Table Field List" on the right, click the Options menu at the top and choose Field List in the top right.
  11. This will be the result:
  12. We now have the data we want but it needs to be formatted:
    1. You can drag the graphical chart to the side to get it out of the way
  13. Next, we need to display the dates as months instead of days
      1. Right-click on any of the dates in the chart and choose Group
      2. Select Months in the list the appears and choose OK
      3. This groups all the EDDs into monthly buckets
  14. The graph defaults to a bar chart, but you can change it:
    1. Right-click the graph and choose Change Chart Type
    2. Select the line graph you'd like
  15. Set the table to update automatically
    1. Highlight the pivot table
    2. Choose the Options menu and in the top-left type the name "EDD Graph"
    3. Click Options below where you just typed
    4. On the Data Tab select Refresh data when opening the file
  16. Finally, rearrange the layout by inserting rows above table to move it down and drag the chart to the top of the page.
  17. You can add titles and legends with the Layout menu
  18. You're final result should look like this:

Step 6: Create Additional Pivot Charts

  1. Repeat all the steps in Step 3 as many times as you'd like to create more charts
  2. In this example, see the screen shot for how the "Patients Received Vaccines" chart was made.
  3. Be sure to set all table to update automatically (Step 15 in the section above)

Step 7: Create Filters

  1. Excel uses "Slicers" to enable users to filter the reports in a user-friendly way.
  2. For the first pivot table you created do the following:
    1. Select the chart you created
    2. Choose Analyze menu at the top
      1. You may need to select Options menu instead
    3. Choose Insert Slicer from the menus
    4. Select the items you will want to filter your reports by and click OK.
    5. Drag the filters and resize them to fit the layout as you like

  3. Now we want this filter to apply to all charts in our Worksheet, so we connect the filters to the other tables by:
    1. Select one of the filters you just created
    2. Choose Options then PivotTable Connections
    3. Check all the boxes for the other tables you created.
    4. Now changing this filter will change the filters on all the tables you created.
    5. Repeat this step for all filters
  4. Copy and Paste the filters to other areas of your Excel sheet if you'd like them to appear in more than one place

Step 8: Build the Dashboard with Copy-Paste

If you'd like to display all the charts on one page, you can copy and paste the reports and table anywhere you'd like

  1. Create a new tab called Dashboard
  2. Copy and Paste the charts from other tabs in to the dashboard tab
  3. Copy and Paste the filters you created, if you'd like
  4. A sample dashboard looks like:

Step 9: Hide the Raw Data

One of the challenges with Excel reporting is ensuring that users you send the reports to do not accidentally corrupt the data or people get confused with too many options.  We can mitigate many of these issues with two methods:

  1. "Protect" all data
    1. Right-click each tab and choose Protect Sheet
    2. Scroll to the bottom of the list and check the box for Edit Objects and Use PivotTable Reports
      1. This will allow users to change filters but not edit the data
      2. Do NOT protect the "Raw Data" tab or the data will not update automatically
  2. Hide the Raw Data tab (if desired)
    1. If you'd like to hide the raw data tab, you can right-click it and choose Hide
    2. To unhide, right click on any sheet name, choose Unhide. It would show you the list of hidden sheets and you can pick the one to unhide.
  3. Choose PivotTable option in Step 4
    1. Instead of putting the raw data on a tab you can directly make pivot tables when importing.
    2. This means the raw data tab will not exist but the pivot tables will.

Step 10: Refresh Your Data

Each night CommCare will save the updated data to that file.  To have Excel pull in the latest, do the following:

  1. Choose Data menu
  2. Click Refresh All
  3. This will pull the latest data from CommCareHQ. You will be prompted for your password.

Step 11: Send to Others

If you just send the Excel file to others they will be prompted to enter login credentials in order to refresh the data. If you don't want this to happen, you can do the following:

Option 1: Delete the Connection to the Raw Data file

  1. In the Data menu choose Connections
  2. Select the Connection you made and choose Remove
  3. This file will no longer update automatically but will still retain the most recent data.

Option 2: Export to pdf (might not be available on all computers)

  1. Chosse File - Save As
  2. Select PDF as the File Type
  • No labels