You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 35 Next »

Overview

This tutorial will walk you through how to use Microsoft Excel to build a simple dashboard using CommCareHQ data exports.  By the end of the tutorial you will be able to create a dashboard that:

  1. Requires upfront work by an administrator just once, and then is easy to maintain going forward
  2. Refreshes automatically when you download a new data export from CommCareHQ.
  3. Allows users to filter the dashboard for information relevant to them without detailed knowledge of how Excel tables work.
  4. Enables an administrator to quickly make new reports and send to end users.

The intended audience for this page is a CommCare administrator who is familiar with CommCareHQ and has some experience in Excel.  The end result will contain the following:

**** Download the Example Dashboard **** 

 

A graphical dashboard

Individual pages with data:

User definable filters:

Getting Started

Excel Version: This tutorial was written for Microsoft Excel 2010. Most of the functionality described is also available in earlier versions of Excel though may be called different names.

Data Files:

Report Dashboard.xlsx: The Dashboard file.  Open this to see the final product.  *** You will get errors upon opening because the Raw Data file is not present, but just say OK and it will still work.  See Troubleshooting section at the bottom to point the file to your Raw Data ***

Raw Data.csv: The raw data downloaded from CommCare. Save this to your computer and follow the instructions in the Troubleshooting section at the bottom.

Export from CommCare.zip: The zip file that contains Raw Data.csv that is downloaded from CommCareHQ.

CommCareHQ Application from the App Exchange (Coming Soon)This tutorial uses a very simple "Pregnancy Tracker" application to create the example data.  You can download this application from the Exchange to try yourself shortly.

Step 1: Create the data export and download data

  1. See this page for details on creating the data export: Data Export Overview
    1. For Export Name name it "Raw Data"
    2. For Default File Type choose CSV (zip file) as the Default File Type.  Excel won't recognize dates properly if you use an Excel file type.
    3. Be sure to rename your Display columns to how you want them to display in your reports.
  2. Download your export and save the zip file to your computer
    1. If it is not a zip file, you need to edit the export and choose CSV as the default file type
  3. Unzip the file you downloaded. It should contain a file called "Raw Data.csv"
  4. Your exported data will look like the below picture:

  

Step 2: Create the Report File and Import the Data

The next step is to create the file that will hold the reports. This is a separate Excel file than your raw data file.  This way you can update the raw data without having to change the reports file.

  1. In Excel, Create a New File.
  2. Save the file as "Reports.xlsx" in the same directory that you save the export in Step 1.
  3. You will have a blank Excel file now.
  4. Now we will pull in the data from the csv file
    1. Choose the Data menu
    2. Choose From Text in the "Get External Data" options in the top left
    3. Browse and select your "Raw Data.csv" file from step 1
    4. On the first screen choose Delimited and click Next.
    5. On the second screen check the box for Comma and uncheck all other boxes. Click Next.
    6. On the third screen click Finish.
    7. Choose New Worksheet in the next window the click "Properties..."
    8. In the Properties window check the box for Refresh data when opening the file
      1. This will make the data update every time you download new data from CommCareHQ

    9. Click OK
    10. Rename the tab "Raw Data"
    11. You now have the data in your reports file and it will automatically update each time you open the file with your most recently downloaded data.

Step 3: Create the first Pivot Chart

The first chart we will create is the Line Graph of Expected Delivery Date.  This will plot the number of women expected to give birth in each month, broken down by Clinic.

  1. Create a new tab called "Expected Delivery Date"
  2. Select the top-left cell (A1) in this tab
  3. In the Insert menu choose Pivot Chart from the PivotTable icon
  4. In the window that pops up, click the icon next to "Table/Range" to select the data the pivot table will use.
  5. Go to the Raw Data tab and select all the columns
  6. The small window should populate with 'Raw Data'!$A:$E. Click the icon next to that.
  7. Click Ok.
  8. This creates a blank pivot table.
  9. Click the pivot table on the left
  10. In the Field list on the right, do the following:
    1. Drag Expected Delivery Date to "Row Labels"
    2. Drag District to "Column Labels"
    3. Drag District to "Values"
    4. Note: If you don't see the "Pivot Table Field List" on the right, click the Options menu at the top and choose Field List in the top right.
  11. This will be the result:
  12. We now have the data we want but it needs to be formatted:
    1. You can drag the graphical chart to the side to get it out of the way
  13. Next, we need to display the dates as months instead of days
      1. Right-click on any of the dates in the chart and choose Group
      2. Select Months in the list the appears and choose OK
      3. This groups all the EDDs into monthly buckets
  14. The graph defaults to a bar chart, but you can change it:
    1. Right-click the graph and choose Change Chart Type
    2. Select the line graph you'd like
  15. Set the table to update automatically
    1. Highlight the pivot table
    2. Choose the Options menu and in the top-left type the name "EDD Graph"
    3. Click Options below where you just typed
    4. On the Data Tab select Refresh data when opening the file
  16. Finally, rearrange the layout by inserting rows above table to move it down and drag the chart to the top of the page.
  17. You can add titles and legends with the Layout menu
  18. You're final result should look like this:

Step 4: Create Additional Pivot Charts

  1. Repeat all the steps in Step 3 as many times as you'd like to create more charts
  2. In this example, see the screen shot for how the "Patients Received Vaccines" chart was made.
  3. Be sure to set all table to update automatically (Step 15 in the section above)

Step 5: Create Filters

  1. Excel uses "Slicers" to enable users to filter the reports in a user-friendly way.
  2. For the first pivot table you created do the following:
    1. Select the chart you created
    2. Choose Analyze menu at the top
      1. You may need to select Options menu instead
    3. Choose Insert Slicer from the menus
    4. Select the items you will want to filter your reports by and click OK.
    5. Drag the filters and resize them to fit the layout as you like

  3. Now we want this filter to apply to all charts in our Worksheet, so we connect the filters to the other tables by:
    1. Select one of the filters you just created
    2. Choose Options then PivotTable Connections
    3. Check all the boxes for the other tables you created.
    4. Now changing this filter will change the filters on all the tables you created.
    5. Repeat this step for all filters
  4. Copy and Paste the filters to other areas of your Excel sheet if you'd like them to appear in more than one place

Step 6: Build the Dashboard with Copy-Paste

If you'd like to display all the charts on one page, you can copy and paste the reports and table anywhere you'd like

  1. Create a new tab called Dashboard
  2. Copy and Paste the charts from other tabs in to the dashboard tab
  3. Copy and Paste the filters you created, if you'd like
  4. A sample dashboard looks like:

Step 7: Hide the Raw Data

One of the challenges with Excel reporting is ensuring that users you send the reports to do not accidentally corrupt the data or people get confused with too many options.  We can mitigate many of these issues with two methods:

  1. "Protect" all data
    1. Right-click each tab and choose Protect Sheet
    2. Scroll to the bottom of the list and check the box for Edit Objects and Use PivotTable Reports
      1. This will allow users to change filters but not edit the data
      2. Do NOT protect the "Raw Data" tab or the data will not update automatically
  2. Hide the Raw Data tab (if desired)
    1. If you'd like to hide the raw data tab, you can right-click it and choose Hide
    2. Quick tutorial on hiding/unhiding sheets: http://www.howtogeek.com/howto/14160/hide-and-unhide-worksheets-and-workbooks-in-excel-2007-2010/

Step 8: Test it out

To test that everything is updating properly, do the following:

  1. Make changes to the data in CommCare or directly in your raw data file.
  2. Download a new version of the export
  3. Unzip the export and save it as the same name as the old export file.
  4. Open and close the Reports Excel file.
  5. Confirm the data was updated.

Step 9: Send to Others

If you just send the Excel file to others they will get errors when they open it since it will look for the raw data file but not find it.  You can do the following when sending to others:

Option 1: Delete the Connection to the Raw Data file

  1. In the Data menu choose Connections
  2. Select the Connection you made and choose Remove
  3. This file will no longer update automatically but will still retain the most recent data.

Option 2: Export to pdf (might not be available on all computers)

  1. Chosse File - Save As
  2. Select PDF as the File Type

Troubleshooting

"Excel cannot find the text file to refresh this external data range"

This means the data export file has either been renamed or does not exist.

  1.  Check that the raw data is in the folder with the correct name.
  2. If still have an issue, reset the data connection by choosing Data -> Connections and edit the connection you made. Browse to the correct file and select it.

 

  • No labels