Tutorial: Create an Excel Dashboard
This page walks through building an Excel dashboard with data from CommCare. Similar to how Excel helps people build spreadsheets, CommCare
enables anyone to build a free customized mobile app - no IT background required. After collecting data with your CommCare app (don't yet have an
account? Sign up for a free trial here.) you can download your data and load it in Excel to create dashboards.
Excel Dashboards require a CommCare Software Plan
This feature (Excel Dashboards) is only available to CommCare users with a Standard Plan or higher. For more details, please proceed to Com
mCare Software Plan page.

Note: Mac users - Excel dashboard integrations are primarily designed for PCs. Mac users should consider data extraction methods such as the data
export tool, manual exports, or the daily saved export.
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Overview
This tutorial will walk you through how to use Microsoft Excel to build a simple dashboard using CommCareHQ data exports. By the end of the tutorial you
will be able to create a dashboard that:
1.
2.
3.
4.

Requires upfront work by an administrator just once, and then is easy to maintain going forward
Refreshes automatically from CommCareHQ when you reopen the report (or set time based refresh).
Allows users to filter the dashboard for information relevant to them without detailed knowledge of how Excel tables work.
Enables an administrator to quickly make new reports and send to end users.

The intended audience for this page is a CommCare administrator who is familiar with CommCareHQ and has
some experience in Excel. The end result will contain the following:

**** Download the Example Dashboard ****

A graphical dashboard

Individual pages with data:

User definable filters:

Getting Started
This tutorial was written for Microsoft Excel 2010 . Most of the functionality described is also available in
earlier versions of Excel though may be called different names.
Excel Version:

Data Files:

CommCare Dashboard.xlsx: The Dashboard file. Open this to see the final product.
Raw Data.csv: The raw data downloaded from CommCare for reference.

Step 1: Create Custom Export in HQ for the project
1. Proceed to the Data section of CommCareHQ.
2. Select Excel Dashboard on the left-hand side.

3. See this Data Export Overview page for details on creating the data export:
a. Name your export
b. Choose Automatically convert dates for Excel
c. Be sure to rename your Display columns to how you want them to display in your reports.
4. Save the export

Step 2: Copy the Web Address of your saved export
We will use the Excel Dashboard Integration report that we created to populate the dashboard. Follow these steps to configure your Excel sheet to pull the
latest data from the report:
1.
2.
3.
4.

In the main Exports section you will see your saved daily export.
Click Update Data button to generate the first report. You may need to refresh the page to confirm that the update is complete.
Select the Copy Dashboard Feed Link button.
Select the Copy Dashboard Feed Link button again to copy the URL. This will copy the URL of the export file so you can paste into Excel in the
next step.
a. Alternatively, you could simply highlight the URL to copy it.

Step 3: Create the Excel Connection to your export
The next step is to create the file that will hold the reports.
1.
2.
3.
4.
5.
6.
7.

In Excel, Create a New File.
You will have a blank Excel file now.
Go to a blank tab in your workbook. Rename that sheet "Raw Data".
Select the top-left cell (A1).
Now we will pull in the data from the Excel file
Choose the Data menu
Choose From Web in the "Get External Data" section (NOTE: If you are getting issues when trying to import data to the web, you may want to
use From Web (Legacy) instead of the standard From Web. Please see Alternative Web Data Access Method for Step 3, below)

8. Be sure you have Copy link address from step 2 above so it is on your clipboard.
9. The "New Web Query" window appears.
10. In the "Address" bar at the top, Paste the link you address you copied in Step 2 above. It should be something like "https://www.commcarehq.org
/a/excelreportingdemo/reports/export/saved/download/96c41fd6fb9be6119ad32467254cbc9a/"
11. Click Go
12. The "Windows Security" window appears. Type your CommCareHQ username and password.
13. The export will be displayed to you in the Web Query Window
14. Click the second Yellow Arrow

above the table of data (not the very top one). This will select all the CommCare data in the export.

15. Click Import

16. The "Import Data" window appears.
17. Click Properties
18. The "External Data Range" window appears
a. In the top of the window, name your export "Raw Data"
b. Choose Save query definition
c. Choose Enable background refresh
d. Choose Preserve Cell Formatting
e. Choose Adjust column width
f. Choose Overwrite existing cells with new data, clear unused cells
g. Choose Fill down formulas in columns adjacent to data
h. Click OK

19. Click OK again
20. The data is pasted into the empty worksheet

Alternative Web Data Access Method for Step 3
Some users experience errors when attempting to import data using the standard "From Web" functionality. Specifically, you may encounter a persistent
error similar to:

Details: "The credentials provided cannot be used for the Web source. Please update the credential type through a refresh or in the
Data Source Settings dialog to continue. (Source at https://www.commcarehq.org/.)"
If you are encountering this error, please make sure Microsoft Office and your OS are up to date, and that your computer has been restarted since
performing these updates. If, after updating everything, you still encounter this error, you may find more success using a legacy version of the From Web
tool. The following instructions allow to access the tool in Excel 2016:
1.
2.
3.
4.
5.
6.
7.

Navigate to File -> Options to open the options window.
Click Customize Ribbon in the pane on the left.
In the dropdown under Choose commands from: select All Commands
Find From Web (Legacy) in the scrolling menu on the left.
In the right-hand menu, select the Data
Click New Group to create a custom group. Rename it if you want.
Select the group you just created and click Add >>

After following the above steps, you should now have access to From Web (Legacy) in the Data ribbon. Now, whenever you want to import data from the
web, instead of clicking From Web in step 7, you will select From Web (Legacy).

Step 4: Name your raw data for easy reference later
1.
2.
3.
4.
5.

Now that your data is in the Raw Data tab, we want to name it so we can refer to the data later
Select all the columns that have data in them by clicking on the top of the columns while holding shift.
With the columns selected, click in the text box above column A (It likely says "A1" in it)
This is where you type the name of the raw data for reference later. Name it "raw_data".
Now, whenever you want to reference the raw data you can type "raw_data" in the formula instead of "='Raw Data'!A:E" like you normally would.

Step 5: Create the first Pivot Chart
The first chart we will create is the Line Graph of Expected Delivery Date. This will plot the number of women expected to give birth in each month, broken
down by Clinic.
1. Create a new tab called "Expected Delivery Date"
2. Select the top-left cell (A1) in this tab
3. In the Insert menu choose Pivot Chart from the PivotTable icon

4. In the window that pops up, click "Table/Range" text box

5. Type "raw_data" into the box. This references the data range we created in the step above and is a lot easier than selecting all the columns each
time.

6. Click Ok.
7. This creates a blank pivot table. (If this doesn't work it's likely because the range is referencing only to the first tab. Go back to step 4.2, then click
"Formulas" at the top, next to "Name Manager" click on "Define Name", enter "raw_data" under "Name" and make sure "Scope" is set to
"Workbook" as this will ensure the reference can be used in different tabs, click OK)
8. Click the pivot table on the left
9. In the Field list on the right, do the following:
a. Drag Expected Delivery Date to "Row Labels"
b. Drag District to "Column Labels"
c. Drag District to "Values"
d. Note: If you don't see the "Pivot Table Field List" on the right, click the Options menu at the top and choose Field List in the top right.
10. This will be the result:

11. We now have the data we want but it needs to be formatted:
a. You can drag the graphical chart to the side to get it out of the way
12. Next, we need to display the dates as months instead of days
i. Right-click on any of the dates in the pivot table and choose Group
ii. Select Months in the list the appears and choose OK
iii. This groups all the EDDs into monthly buckets

13. The graph defaults to a bar chart, but you can change it:
a. Right-click the graph and choose Change Chart Type
b. Select the line graph you'd like
14. Set the table to update automatically
a. Highlight the pivot table
b. Choose the Options menu and in the top-left type the name "EDD Graph"
c. Click Options below where you just typed

d. On the Data Tab select Refresh data when opening the file

15. Finally, rearrange the layout by inserting rows above table to move it down and drag the chart to the top of the page.
16. You can add titles and legends with the Layout menu
17. You're final result should look like this:

Step 6: Create Additional Pivot Charts
1. Repeat all the steps in Step 5 as many times as you'd like to create more charts
2. In this example, see the screen shot for how the "Patients Received Vaccines" chart was made.
3. Be sure to set all table to update automatically (Step 15 in the section above)

Step 7: Create Filters
1. Excel uses "Slicers" to enable users to filter the reports in a user-friendly way.
2. For the first pivot table you created do the following:
a. Select the chart you created
b. Choose Analyze menu at the top
i. You may need to select Options menu instead
c. Choose Insert Slicer from the menus

d. Select the items you will want to filter your reports by and click OK.
e. Drag the filters and resize them to fit the layout as you like

3. Now we want this filter to apply to all charts in our Worksheet, so we connect the filters to the other tables by:
a. Select one of the filters you just created
b. Choose Options then PivotTable Connections

c. Check all the boxes for the other tables you created.
d. Now changing this filter will change the filters on all the tables you created.
e. Repeat this step for all filters
4. Copy and Paste the filters to other areas of your Excel sheet if you'd like them to appear in more than one place

Step 8: Build the Dashboard with Copy-Paste
If you'd like to display all the charts on one page, you can copy and paste the reports and table anywhere you'd like
1.
2.
3.
4.

Create a new tab called Dashboard
Copy and Paste the charts from other tabs in to the dashboard tab
Copy and Paste the filters you created, if you'd like
A sample dashboard looks like:

Step 9: Hide the Raw Data
One of the challenges with Excel reporting is ensuring that users you send the reports to do not accidentally corrupt the data or people get confused with
too many options. We can mitigate many of these issues with two methods:
1. "Protect" all data
a. Right-click each tab and choose Protect Sheet
b. Scroll to the bottom of the list and check the box for Edit Objects and Use PivotTable Reports
i. This will allow users to change filters but not edit the data
ii. Do NOT protect the "Raw Data" tab or the data will not update automatically
2. Hide the Raw Data tab (if desired)
a. If you'd like to hide the raw data tab, you can right-click it and choose Hide
b. To unhide, right click on any sheet name, choose Unhide. It would show you the list of hidden sheets and you can pick the one to unhide.
3. Choose PivotTable option in Step 4
a. Instead of putting the raw data on a tab you can directly make pivot tables when importing.
b. This means the raw data tab will not exist but the pivot tables will.

Step 10: Refresh Your Data
Each night CommCare will save the updated data to that file. To have Excel pull in the latest, do the following:
1. Choose Data menu
2. Click Refresh All
3. This will pull the latest data from CommCareHQ. You will be prompted for your password.
If Excel hangs during the refresh, disable Enable Background Refresh on all data connections. This is a known problem for spreadsheets with multiple
web-based data connections. Find it under Data -> Connections -> Select Connection, click Properties -> unselect Enable Background Refresh.

NOTE: The data needs to be pulled/downloaded every 35 days (see warning label below) to maintain an active data connection/link. This can be achieved
by clicking on Refresh All in the Excel dashboard (see instructions above). Otherwise, the data connection will expire and Step 3 needs to be repeated to
re-establish a data connection.

Step 11: Send to Others
If you just send the Excel file to others they will be prompted to enter login credentials in order to refresh the data. If you don't want this to happen, you can
do the following:
Option 1: Delete the Connection to the Raw Data file
1. In the Data menu choose Connections
2. Select the Connection you made and choose Remove
3. This file will no longer update automatically but will still retain the most recent data.
Option 2: Export to pdf (might not be available on all computers)
a. Chosse File - Save As
b. Select PDF as the File Type

